Some users are experiencing slowness and errors when using Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing some users to experience slowness and errors when using Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Feb 20, 2020 - 00:39 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Feb 20, 2020 - 00:29 UTC
Investigating
We’re currently aware of an issue where some users are experiencing slowness and errors when using Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 20, 2020 - 00:09 UTC
This incident affected: Xero.