Global: Invoicing - Some users are receiving errors when trying to preview or send an online invoice from Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 22:27 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 22:09PM
Posted Nov 17, 2024 - 22:09 UTC
Investigating
We are aware some customers are experiencing issues when trying to access New Invoicing. Our team is investigating this with urgency.

Status Last Reviewed: 22:01pm
Posted Nov 17, 2024 - 22:01 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).