Users are currently experiencing performance issues with Xero Payroll
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 01:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2022 - 00:27 UTC
Investigating
We’re currently aware of an issue experiencing intermittent issues with Xero Payroll. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jan 25, 2022 - 00:17 UTC
This incident affected: Xero.