Global: Some customers are unable to access Bills and Invoices in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue customers experienced where they were unable to access Bills and Invoices. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Nov 20, 2023 - 06:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 20, 2023 - 06:12 UTC
Investigating
We are aware some customers are unable to access Bills and Invoices in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 4:13am UTC
Posted Nov 20, 2023 - 04:13 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).