Global: Xero - some users may be experiencing an error page when logging into Xero.

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to log into Xero. We apologise for any inconvenience this has caused.

A product release caused Xero to become unavailable tempoararily.
We learn from every incident and put measures in place to prevent issues from happening again.
Posted Mar 10, 2026 - 01:54 UTC

Monitoring

We are aware customers trying to log into Xero are experiencing an error. Our team is investigating this with urgency.
Posted Mar 10, 2026 - 01:38 UTC
This incident affected: Xero Platform and Settings.