Some users are unable to access Batch Payments in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from creating Batch Payments.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Sep 21, 2020 - 04:03 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to create Batch Payments as soon as possible.
Posted Sep 21, 2020 - 03:46 UTC
Investigating
We’re currently aware of an issue preventing some users from creating Batch Payments in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Sep 21, 2020 - 03:27 UTC
This incident affected: Xero.