Global: XPM - Some customers are experiencing issues
Incident Report for Xero
Resolved
This incident has been resolved.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Mar 08, 2023 - 00:57 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:04AM UTC
Posted Mar 08, 2023 - 00:04 UTC
Investigating
We are aware some customers trying to navigate in XPM are experiencing performance issues. Our team is investigating this with urgency.

Status Last Reviewed: 11:55pm UTC
Posted Mar 07, 2023 - 23:56 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).