Some Payroll users are getting timeouts in Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 06:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2021 - 06:21 UTC
Investigating
We’re currently aware of an issue where some Payroll users are getting timeouts in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 30, 2021 - 06:17 UTC
This incident affected: Xero.