Our team has resolved the issue causing customers to experience slowness or errors in Expenses. We apologise for any inconvenience this has caused.
Our technical team identified this was caused by poor network connectivity.
Posted Nov 22, 2024 - 00:33 UTC
Monitoring
We have identified what is causing customers to experience slowness or error messages when creating or approving Expenses.
The team have implemented a fix, and are monitoring the results.
Status Last Reviewed:11:39pm UTC
Posted Nov 21, 2024 - 23:45 UTC
Update
Our product team is looking into this, and we’ll provide an update as soon as possible
Posted Nov 21, 2024 - 21:02 UTC
Update
We are continuing to investigate this issue.
Posted Nov 21, 2024 - 20:41 UTC
Update
We are continuing to investigate this issue.
Posted Nov 21, 2024 - 19:43 UTC
Investigating
We are aware customers may be experiencing slowness or error messages when creating or approving Expenses. Our team is investigating this with urgency.
Status Last Reviewed:11:24pm UTC
Posted Nov 21, 2024 - 19:17 UTC
This incident affected: Core Xero Products (Expenses).