UK: Delay with processing HMRC connected services (CIS, Corporate Tax, Personal Tax, Partnership Tax, Payroll)

Incident Report for Xero

Identified

HMRC have let us know that there is an ongoing investigation into the delayed responses from their services which is impacting UK customers using CIS, Personal tax, Partnership Tax, Payroll and Corporation tax.
Posted Sep 14, 2026 - 15:53 UTC

Investigating

We're aware that UK customers using CIS, Personal tax, Partnership Tax, Payroll and Corporation tax may experience a delay in filings processing. This is due to our systems receiving errors from HMRC's services. We have contacted HMRC for assistance.
Posted Sep 14, 2026 - 15:08 UTC
This incident affects: United Kingdom - Regional Products (UK Payroll).