Our team has resolved the issue impacting some customers trying to view a Quote in Xero. We apologise for any inconvenience this has caused.
Our technical team identified that this related to network stability issues with one of the external services that several of our Xero products use.
Posted Sep 23, 2024 - 04:14 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 4:06 UTC
Posted Sep 23, 2024 - 02:19 UTC
Identified
We have identified what is preventing some customers trying to view a Quote in Xero.
This is our top priority and we will update you as soon as we can. In the meantime we'd recommend clearing your browser's cookies and cache, as we've noted this restores the ability to view a Quote in Xero.
Status Last Reviewed: 02:02 UTC
Posted Sep 22, 2024 - 22:28 UTC
Investigating
We are aware that some customers trying to view a quote in Xero are experiencing a blank screen. Our team is investigating this with urgency.
Status Last Reviewed: 22:26 UTC
Posted Sep 22, 2024 - 20:59 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).