Some users are experiencing slowness in some areas of Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing the Performance loss to some of our UK customers.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 2 months ago. Nov 07, 2018 - 03:19 NZDT
Identified
Our Product Team have identified the cause, and are working to resolve the Performance Issues as soon as possible
Posted 2 months ago. Nov 07, 2018 - 03:13 NZDT
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted 2 months ago. Nov 07, 2018 - 02:40 NZDT
Update
Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 2 months ago. Nov 07, 2018 - 02:07 NZDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Nov 07, 2018 - 01:29 NZDT
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted 2 months ago. Nov 07, 2018 - 01:05 NZDT
Update
Our Product Team are doing everything they can to resolve the issues with Performance. Thanks for your patience.
Posted 2 months ago. Nov 07, 2018 - 00:14 NZDT
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 2 months ago. Nov 06, 2018 - 23:40 NZDT
Investigating
We’re currently aware of an issue were users are experiencing slowness in some areas of Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 2 months ago. Nov 06, 2018 - 23:15 NZDT
This incident affected: Xero.