Slowness and errors while accessing XPM
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 05:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 13, 2021 - 05:02 UTC
Investigating
Users experiencing slowness and errors while accessing Xero Practice Manager.
Posted Jul 13, 2021 - 04:50 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).