Some users are experiencing errors and slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue where some users were experiencing slowness and errors in Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Feb 28, 2020 - 05:26 UTC
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted Feb 28, 2020 - 03:36 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Feb 28, 2020 - 02:27 UTC
Update
Our Product Team are doing everything they can to let you use Xero. Thanks for your patience.
Posted Feb 28, 2020 - 01:45 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Feb 28, 2020 - 01:18 UTC
Investigating
We’re currently aware of an issue where some users are experiencing errors and slowness in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 28, 2020 - 01:01 UTC
This incident affected: Xero.