Some users are experiencing slowness and errors in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing a small number of users from logging into Xero.

If you continue to have issues, please clear your browser's cookies and cache.
Apologies for any inconvenience caused by this issue.

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted Jul 03, 2020 - 00:51 UTC
Investigating
We’re currently aware of an issue preventing a small number of users from accessing Payroll and Reporting areas in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jul 03, 2020 - 00:38 UTC
This incident affected: Xero.