Users experiencing slow performance in Reporting
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Dec 09, 2020 - 09:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2020 - 07:35 UTC
Update
We are continuing to investigate this issue.
Posted Dec 09, 2020 - 05:46 UTC
Update
Our Product Team are doing everything they can to let you access reports area in Xero. Thanks for your patience.
Posted Dec 09, 2020 - 05:14 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Dec 09, 2020 - 04:27 UTC
Investigating
We’re currently aware of an issue preventing users from accessing reports in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Dec 09, 2020 - 03:50 UTC
This incident affected: Xero Platform and Settings.