WFM customers experiencing degraded performance
Incident Report for Xero
Resolved
We have resolved the issue that was causing customers to experience degraded performance in WFM. This issue was caused by system maintenance and we apologise for any inconvenience.
Posted Nov 06, 2022 - 21:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2022 - 21:20 UTC
Investigating
We are aware customers using WorkflowMax are experiencing degraded performance. Our team is investigating this with urgency.

Status Last Reviewed: 9:20pm UTC
Posted Nov 06, 2022 - 20:58 UTC
This incident affected: WorkflowMax.