Global: Xero - Some customers may be experiencing increased time delays or errors when using certain products of Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to navigate across multiple products in Xero. We apologise for any inconvenience this has caused.

Within 24 hours we’ll update this page with a brief summary
Posted Sep 11, 2025 - 18:36 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results

Status Last Reviewed: 17:47pm UTC
Posted Sep 11, 2025 - 17:47 UTC

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 12:21 UTC

Investigating

We are aware customers trying to navigate across multiple products in Xero are experiencing delays or errors. Our team is investigating this with urgency.

Status Last Reviewed: 12:20pm UTC
Posted Sep 11, 2025 - 12:20 UTC
This incident affected: Xero Platform and Settings.