Global: Intermittent issues in Xero

Incident Report for Xero

Resolved

This incident has been resolved. Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Mar 07, 2023 - 21:51 UTC

Investigating

We are aware that some customers trying to access Xero are experiencing intermittent issues. Our team is investigating this with urgency.

Status Last Reviewed: 9:38pm UTC
Posted Mar 07, 2023 - 21:38 UTC