Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 16, 2025 - 06:45 UTC
Scheduled
Our third party provider, Salesforce will be undertaking scheduled maintenance on Sunday, 16 February from 6.45am to 8.45am UTC.
During this time, Xero customers will be unable to access any content within Xero Central or provide feedback to our Xero Support team.
If you need to access any Xero Central content during this time, you can do so through the Help Menu in Xero. You can still access learning content and register for courses and webinars by visiting learning.central.xero.com
We thank you for your patience during this time.
Posted Feb 12, 2025 - 22:13 UTC
This scheduled maintenance affected: Xero Central.