NZ: NZ GST returns - Unable to access GST returns
Incident Report for Xero
Resolved
Our team has resolved the issue impacting NZ customers from drilling down into their GST returns. We apologise for any inconvenience this has caused.

Within 24 hours we’ll update this page with a brief summary
Posted Feb 15, 2023 - 01:56 UTC
Investigating
We are aware NZ customers trying to drill down into their GST returns are experiencing an error message. Our team is investigating this with urgency.

Status Last Reviewed: 1:10 AM UTC
Posted Feb 15, 2023 - 01:10 UTC
This incident affected: New Zealand - Regional Products (Tax Reporting - NZ GST).