Performance issues in Xero Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was affecting the performance in Xero Payroll.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 3 months ago. Jul 02, 2018 - 20:04 NZST
Update
We apologise for any inconvenience caused, our Product Team are working on a solution.
Posted 3 months ago. Jul 02, 2018 - 19:25 NZST
Update
We are still monitoring the situation to ensure the issue has been fully resolved.
Posted 3 months ago. Jul 02, 2018 - 18:07 NZST
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted 3 months ago. Jul 02, 2018 - 17:02 NZST
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted 3 months ago. Jul 02, 2018 - 16:07 NZST
Monitoring
Our Product Team are seeing an improvement in Payroll performance in Xero, we are currently monitoring the situation and will provide an update as soon as possible.
Posted 3 months ago. Jul 02, 2018 - 15:27 NZST
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted 3 months ago. Jul 02, 2018 - 14:56 NZST
Identified
Our Product Team have identified the cause, and are working to restore performance to Xero Payroll as soon as possible.
Posted 3 months ago. Jul 02, 2018 - 14:32 NZST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 02, 2018 - 14:21 NZST
This incident affected: Xero.