Global: Xero - Some customers may be experiencing slowness across Xero
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to navigate multiple products in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 05, 2024 - 01:26 UTC
Monitoring
A fix has been applied and we are currently monitoring the results.
Posted Sep 05, 2024 - 00:42 UTC
Update
We’re aware some customers are experiencing slowness navigating some Xero products. We have identified what is causing the impact and resolving this is our top priority. We thank customers for their patience.

Status Last Reviewed: 12:27am UTC
Posted Sep 05, 2024 - 00:28 UTC
Identified
We have identified what is impacting some customers trying to use multiple products across Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 12:22am UTC
Posted Sep 04, 2024 - 22:57 UTC
Investigating
We are aware some customers trying to access multiple products in Xero are experiencing slowness. Our team is investigating this with urgency.

Status Last Reviewed: 10:45pm UTC
Posted Sep 04, 2024 - 22:10 UTC
This incident affected: Xero Platform and Settings.